FacebookTwitterLinkedIn
Login / Register

Login / Register

IUG FORUM

Stay always connected!
  1. Jennifer Faist
  2. Sierra/ Millennium/ Encore
  3. Wednesday, January 25 2017, 05:18 PM
  4.  Subscribe via email
We have found that we are having problems viewing infographics on Statista through the WAM proxy, but only on campus. Everything works fine off campus. All of our SAN entries and WAM forward table entries checked out okay. I took a look at the security info for the infographics in the browser and they are going through the proxy. I can see the rewritten URLs, but on campus the pixel arrays are 0px x 0px, whereas off campus they are their normal pixel arrays. If I take the URL out of the proxy rewrite, everything works fine on campus.

I have made some progress in isolating the cause of the problem. I was trying to figure out what the difference was between accessing Statista from off campus vs. on campus. I noticed that the link on our Online Resources page is http://0-www.statista.com.library.artcenter.edu/ which gets redirected to https://0-www.statista.com.library.artcenter.edu/. The difference is the order of the steps and where the SSO login comes into play.

Off Campus:
Click on the http link on the Online Resource page
Go through SSO login
Get redirected to https URL
Infographics display

On Campus:
Click on the http link on the Online Resource page
Get redirected to https URL
Go through SSO login (which really shouldn't happen because the service level for on campus is high enough that on-campus patrons should not be asked to be verified, but WAM seems to want to force SSO for anything that is https)
Infographics do not display

So I thought, what happens if I force the SSO to come before the https redirect on campus like it happens off campus? So I changed the Verify Service Level in the WAM forward table to 2 so that both off-campus and on-campus users need to authenticate through SSO first. And it turns out it made a difference, and now infographics are displaying on campus. The problem is this workaround to get the infographics to display isn’t quite ideal because we don’t really want to have to force people to login if they are on campus. Is anyone else is having this problem, or have some insight? We have a ticket open with Statista, but I’ll also open a ticket with Innovative.
Comment
There are no comments made yet.
Add Comment
Accepted Answer
Jennifer Faist Accepted Answer
0
Votes
Undo
Innovative has finally gotten to the bottom of the Statista infographic display issue (Ticket #516133). It appears that there are some links that should not be proxied. They changed the forward table entry to "http://www.statista.com" from "*.statista.com" and we are now able to see the graphs. Some of the download links are dropping out of the proxy without the wildcard entry, but we are still able to download documents, even off campus.

In troubleshooting our issues with Statista, they had advised us to add the following entries in our SAN certificate:

DNS Name: 0-static1.statista.com.library.artcenter.edu
DNS Name: 0-static2.statista.com.library.artcenter.edu
DNS Name: 0-static3.statista.com.library.artcenter.edu
DNS Name: 0-static4.statista.com.library.artcenter.edu
DNS Name: 0-static5.statista.com.library.artcenter.edu
DNS Name: 0-cdn1.statista.com.library.artcenter.edu
DNS Name: 0-cdn2.statista.com.library.artcenter.edu
DNS Name: 0-cdn3.statista.com.library.artcenter.edu
DNS Name: 0-cdn4.statista.com.library.artcenter.edu
DNS Name: 0-cdn5.statista.com.library.artcenter.edu
DNS Name: 0-infographic.statista.com.library.artcenter.edu

With the removal of the wildcard, the static1-5 and cdn1-5 URLs are also not being proxied anymore. If the URLs don’t need to be proxied, then the host name should not be in the forward table or in the SAN certificate. Since we are not seeing any problems, we are assuming that the only entry in the forward table and on the SAN certificate should be "0-http://www.statista.com..." (at this point anyway—database vendors frequently change things around without notice!).

jennifer.faist@artcenter.edu

jennifer.faist@artcenter.edu

jennifer.faist@artcenter.edu

jennifer.faist@artcenter.edu
Comment
The forum keeps throwing in the http in front of the www forward table entry and URLs. Ignore that.

jennifer.faist@artcenter.edu
  1. Jennifer Faist
  2. 3 months ago
There are no comments made yet.
Add Comment


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,pdf,ppt,pptx,doc,docx,xls,xlsx,,txt,rtf,jrxml
• Remove Upload Files (Maximum File Size: 2 MB)
You may insert polls into your post. The poll would then appear in the post.
Vote Options
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.